DocsFlow user guide

Getting started

If you’re really in a hurry, see the “Quick start” sidebar.

Make sure you’re using InDesign CS5 or later, and you know the basics of Google Drive (Docs) usage and the basics of story placing in InDesign.

Download the installer for your version of InDesign and operating system (Mac OS or Windows) from the “DocsFlow for InDesign” sidebar on this pageits product page. Install it by double-clicking the downloaded installer (which is an installer package under Mac OS and an executable under Windows) and following directions.

Start InDesign, and fill in your name, affiliation and normal or Pro-level license code (a.k.a. serial number) when prompted by DocsFlow at first usage. If you just want to try it out, use the Demo button—you’ll have full (including Pro) functionality for 15 days. If you need a license, you can use the Get License button, and then come back when done.

  • Use File > DocsFlow > Place from Google Docs… to select and place a Google Docs document from your account (signing in to Google Docs the first time, at the prompt). You can also place Google Docs spreadsheets in the Pro version.

  • Double-click a link’s change warning icon in the Links panel to update the linked story, merging changes when the Google Docs document has been edited. Or, click the update link (double arrow) icon in the panel with the link selected, or alt/option-click the update link icon to update all links.

  • To see what’s been changed in a story on either side after an update, open the Story Editor. Open the Notes panel to see any DocsFlow-generated notes about editing conflicts. For more details, see handling conflicts (simply stated, WordsFlow leaves a note at each point of irreconcilable conflict).

  • To edit the original Google Docs document, select the linked story in the Links panel, and click the edit original icon at the bottom of the main panel area. (When you return to InDesign, the story will be automatically updated from Google Docs.)

  • In the Pro version, use the Links panel’s per-link menu DocsFlow > Update Original Document (or the and Visit or and Edit menu) to export a story’s changes to the linked Google Docs document, optionally jumping to the document in your default browser to visit or edit.

  • In the Pro version, use File > DocsFlow > Export to Google Docs… (or and Visit…) to export and link a currently unlinked story to a new Google Doc document.

  • If you use your Google Drive account mounted in your file system, place a Google Docs document or spreadsheet from any of your Drive folders by simply dragging and dropping it into InDesign.

See the “DocsFlow support” sidebar on this page or on the main product page to get started dealing with questions or problems.

That should get you started. A reference guide follows, with a table of contents on the upper right.

DocsFlow menu

DocsFlow menuDocsFlow has its own submenu on the File menu, with selections for placing documents from Google Docs, exporting a story to Google Docs, signing in/out of Google Docs, and ancillary items such as visiting this guide, emailing for support, etc.

DocsFlow update-merge of a story from Google Docs is controlled not from here, but from the Links panel item menus and the Links panel buttons, which are described below in the section Managing stories with the Links panel.

Similarly, DocsFlow update-merge from a story back to Google Docs is controlled not from here, but from Links panel link item menus as well.

DocsFlow also has export/update-related menu items in each story’s contextual menu.

Signing in to Google Docs

DocsFlow loginThe first time you invoke File > DocsFlow > Place from Google Docs…, if you haven’t already explicitly signed in with Sign In to Google Docs… from the same sub-menu, you’ll be prompted to sign in to your Google Docs account, which DocsFlow will remember until you explicitly sign out, if Stay signed in is checked (the default).

You can change the account you’re using, and re-sign in as a different user, using DocsFlow > Sign Out ‘user name’ and then Sign In to Google Docs…. Or, when the Place from Google Docs… dialog is showing, you can re-sign in by clicking the button containing your user account name.

The default method is Sign in securely with your browser (technically called “OAuth” sign in). This is the most robust and high-performance solution, and avoids giving DocsFlow your account password.

(Direct login has to use an older and slower method of Google Docs access, and is now entirely deprecated by Google. We’ll be removing this option.)

DocsFlow OAuth promptWhen you sign in securely with your browser, you are taken to a browser page where Google Docs will ask you to sign in (if you’re not already signed in), and then asks you if DocsFlow should be allowed access to your Google Docs files.

Technical detail: DocsFlow supports basic system-wide proxy access automatically, though it won’t work with proxies requiring user-specific authentication.

Placing stories

When you invoke DocsFlow > Place from Google Docs…, you’ll be presented with a dialog listing your Google Docs documents (and spreadsheets in the Pro version) available for placement.DocsFlow place

Your folders and documents are displayed in a familiar tree-like layout, and you can expand and collapse folders using the disclosure triangles on the left. Option/alt-clicking on a folder’s disclosure triangle will toggle between collapsing the folder contents entirely, and expanding them entirely, for faster navigation.

  • Show import options gives you a chance to specify further import options during the placement, if checked; if not checked, DocsFlow will use the most recently-selected preset import options during the placement.
  • Replace selected item works the same as the same option in the normal Place… dialog.
  • Link to document lets you place a document without linking to it, if unchecked. Normally, you’d check this, unless you simply want placement from Google Docs without the dynamic link back to the Google Docs document.

Once you select a Google Docs (“GDocs” below) document and start the placement by pressing the Place button, or double-clicking the desired document in the list, DocsFlow downloads the document from GDocs, gives you a chance to specify further import options if requested (see below), converts the results to ICML (InDesign’s native tagged text format), loads the place gun with the resulting story content, and lets you complete the Place as you would with a normal place gun.

Once the placement is finished, assuming you haven’t unchecked Link to document, DocsFlow creates a live link from the resulting story to the original GDocs document and marks the story with a little “df” icon next to the story’s link icon. DocsFlow also extracts the relevant metadata from the GDocs document (author, creation and modification date, etc.) and makes it part of the InDesign link metadata.

Drag and drop placement from Google Drive

When using the Google Drive filesystem extension under Mac OS or Windows, and signed into the same account under which you’re using DocsFlow, you can place a Google Docs document or spreadsheet by simply dragging and dropping it from its system folder to InDesign. DocsFlow will place the story using the import options set globally or per-document with DocsFlow > Set Import Options….

Drag-and-drop placement can be a bit tricky when InDesign isn’t the active application, as the place gun won’t be loaded (or you can’t see that it’s loaded) until InDesign is made active again. One trick is to simply make the Google Drive folder visible on the desktop, and start and finish the drag and drop with InDesign active. Another is to start the drag in the Finder or Windows Explorer and then, while dragging, make InDesign the active application by using keyboard switching shortcuts, then finish the drop with InDesign active.

Drag and drop placement from the browser

When you’re using Google Docs and viewing/editing a document in your browser, signed into the same account under which you’re using DocsFlow, you can also drag and drop the document’s icon on the left of the URL bar (not the URL itself) to an unused part of the InDesign spread. DocsFlow will give you a place gun, and place the story using the import options set globally or per-document with DocsFlow > Set Import Options….

When using the “new” Google Drive interface and Chrome for Windows (only, for now), you can drag and drop from the file list in the browser. (We hope to expand this to other browsers soon.)

Note that you can’t drag and drop to a text frame directly; you have to drag and drop to an unused part of your InDesign spread. That gives you the normal place gun, which you can then fire on a text frame target, or create a new text frame, as usual.

Using Import Options

DocsFlow import options generalIf you’ve checked Show import options in the Place from Google Docs… dialog, then, during the import, DocsFlow will give you a chance to fine-tune the import using its Import Options dialog.

(Click on any screenshot to view it full-sized.)

Overall, Cancel will cancel any import option settings you’ve made since the last Save Preset…, as well as canceling any ongoing placement. OK will continue with the placement using the current settings.

DocsFlow remembers the most-recently-used options/preset, so you don’t have to go through the import options step, if you’re not changing anything from the previous placement or from your most recent Set Import Options… settings.

Set Import Options…

You can also set up global import options (with no document open), or set and modify the current document’s import options using File > DocsFlow > Set Import Options…. This opens the Import Options dialog and allows you to set the appropriate defaults for future placements. Setting these options is critical in particular for drag-and-drop placement, which doesn’t give you any options during placement.

Import Options: Presets

The top part of this dialog is the “preset” selector and editor.

Selecting a previously-saved preset by name from the pop-up menu will restore those settings.

Save Preset… saves the current settings, after prompting you for a preset name under which to save them. (Use an existing preset name to update that preset with the current settings.)

Delete deletes any currently-selected preset.

The default preset name is [Custom] which just means you’re looking at the current auto-saved settings (so you never really have to use named presets if you always use this default). As soon as you modify anything from the currently-selected preset (that isn’t already [Custom]), DocsFlow will change the preset name to [Custom], showing that it’s been changed. You can you save over the previously-selected preset by typing its name (automatically suggested by DocsFlow), or save under a new preset name.

(In this section’s screenshots, we’re using an example preset Magazine 1 throughout. You would, of course, use whatever name is most appropriate in your situation.)

Import Options: General tab

DocsFlow import options generalThe General tab in the import options dialog contains miscellaneous import controls.

  • Collapse all empty paragraphs controls whether DocsFlow ignores empty paragraphs in the GDocs document when placing or updating. The idea here is that people using GDocs for editing may use two returns to delimit paragraphs, and the extra, empty paragraph resulting from the second return should usually be removed. (Defaults to on.)
  • Convert leading tabs to first line indent controls whether DocsFlow converts any leading tabs in a paragraph to a first-line indent setting.
  • Ignore character attributes controls whether the given properties in GDocs are ignored or not. (Defaults to off, i.e., they’re not ignored.) Turn this on, if you don’t want your GDocs font-related “micro-formatting” to affect your InDesign layout.
  • Ignore paragraph attributes controls whether the given paragraph properties in GDocs are ignored or not. (Defaults to off, i.e., they’re not ignored.) Turn any of these on, if you don’t want the corresponding GDocs paragraph formatting (space before/after, left/right indents, first line indent, line spacing) to affect your InDesign layout.

Import Options: Paragraph tab

DocsFlow import options paragraphThe Paragraph tab in the import options dialog provides a set of controls for mapping GDocs paragraph formats to InDesign paragraph styles during import or update.

Each kind of paragraph-level structure found in a GDocs document—Normal text, Title, Subtitle, Heading 1 through 6, bulleted list items, numbered list items, and horizontal rules—can be mapped to InDesign paragraph styles in one of several ways.

  • name (for any of the current document’s paragraph styles) maps the corresponding GDocs paragraph structure to the document style named name. This is what you’d normally use.
  • (Not Mapped) maps the given GDocs paragraph to the standard InDesign “no paragraph” style, but formats it to match its GDocs appearance (e.g., a Heading 1 would be styled with a big bold font, space above/below, etc.). This is the default.
  • [No Paragraph Style] maps the given GDocs paragraph to the standard InDesign “no paragraph” style, without further formatting.
  • [Basic Paragraph] maps the given GDocs paragraph to the standard InDesign “basic paragraph” style. This is the default for Normal text.
  • DocsFlow:name (where name is one of Title, Subtitle, Heading 1 to 6, Bulleted item, Numbered item, Horizontal rule, etc.) maps the given GDocs paragraph to the DocsFlow-specific InDesign paragraph style. This is the default, except for Normal text.
  • (Other…) prompts for an InDesign paragraph style name and maps the given GDocs paragraph to the named InDesign style, without needing to have the style already defined in the current document. (You shouldn’t ordinarily need to use this.)

For the cases other than (Not Mapped), DocsFlow will apply the appropriate InDesign paragraph style without further formatting, except by applying overrides for any special indentation and alignment (left, center, right, etc.) applied to the original GDocs paragraph.

Any DocsFlow-specific style (e.g., DocsFlow:Heading 1) will be created at import or update, if it doesn’t already exist in the document.

For example, by mapping the styles as shown above in the screenshot, we get the resulting layout shown here, with two columns spanned by the GDocs Heading 1 mapped to an InDesign headline paragraph style, Heading 2 mapped to the deck style, Normal text mapped to body, etc. This example also illustrates how you can use the (CS5 and later) column-spanning and multiple-columns paragraph style settings to build creative geometries without additional text frames.

Import Options: Character tab

DocsFlow import options characterThe Character tab in the import options dialog provides a set of controls for mapping combinations of GDocs character formats to InDesign character styles during import or update.

For each combination of unstyled, bold, italic, and bold italic, and for any text in a standard set of GDocs colors, you can choose how DocsFlow translates GDocs document characters styled with that combination or color.

  • name (for any of the current document’s characters styles) maps the corresponding GDocs style or color to the document style named name. This is what you’d normally use.
  • (Not Mapped) means the character format or color is simply left alone, passed through as itself (unstyled, bold, italic, or bold italic). This is the default.
  • [None] means the character format or color is simply ignored, passed through as unstyled. This would be useful if you want to suppress all bold italic text, for example.
  • (Other…) allows you to select a named character style to apply to the characters in question, without the character style being defined in the current document.

For example, suppose you were publishing a travel guide, and your GDocs users applied italic formatting on all hotel names, bold on all location names, and bold italic on all activity names (sightseeing, fishing, etc.). If you mapped each in turn to the document character styles Hotels, Locations and Activities, then you would have complete control of the styling for each of these entities independently—even after all editing was done—, since they’d each be applied to the appropriate text coming from GDocs.

Import Options: Table and Cell tabs

DocsFlow import options tableThe Table and Cell tabs in the import options dialog provide an identical set of controls for (Table) applying table styles in InDesign, based on the color of the table’s border in GDocs, or (Cell) applying table cell styles in InDesign, based on the color of the cell’s background in GDocs.

By using a color in GDocs and then using the closest-matching color in one of these two tabs to map the GDocs color to a table or cell style, you can achieve nearly any effect, such as alternate row shading in tables, individual cell shading or outlining, etc.

Import Options: Object tab

The Object tab in the import options dialog (not pictured here) provides a single control for applying a single object style to any embedded picture.

Exporting and export-update-merging

Exporting stories to Google Docs

DocsFlow exportIn the Pro version of DocsFlow, you can export any unlinked story to a new Google Docs document by selecting the story and using File > DocsFlow > Export to Google Docs…, then choosing a document name and target folder in the ensuing Export to Google Docs dialog. (If you’re not already signed in to Google Docs, you’ll be prompted with a login dialog before the Export dialog appears.)

Your folders and documents are displayed in a familiar tree-like layout, and you can expand and collapse folders using the disclosure triangles on the left. Option/alt-clicking on a folder’s disclosure triangle will toggle between collapsing the folder contents entirely, and expanding them entirely, for faster navigation.

Clicking on a folder will select it as the target folder. Clicking on a file will select both its parent folder as the target folder, and also select the file’s name as the default name of the new document. (Google Docs won’t mind the duplication, but for your own sanity you should choose a distinct name by editing the name field.)

  • Show import options shows the Import Options dialog to enable you to set up an import mapping. This import mapping is used both for export, where DocsFlow will reverse-map the import options, and for any later update (import-merge), if a link is established.
  • Link to document controls whether a link is established to the exported Google Docs document or not.

DocsFlow then creates a new Google Docs document from the InDesign story at the selected target folder and with the given name, using any given import options to reverse-map styles, etc., and optionally creating a link to the newly-created story (marking the story with a little “df” icon next to the story’s link icon).

Export-update-merging stories to Google Docs

In the Pro version of DocsFlow, once a story is linked, you can export-merge the current story contents into the Google Docs document by selecting DocsFlow > Update Original Document (or and Visit or and Edit) from the Link panel’s link item contextual menu. (You can also select the same from the story’s contextual menu.)

DocsFlow does the same kind of “magic” three-way merge for export-update that it does for import-update, looking only at the changes on the InDesign side, and merging those in to the Google Docs document with as little disturbance to the formatting as possible.

When DocsFlow export-updates a linked Google Docs document from an InDesign story, DocsFlow will let the InDesign text, the merge’s source, dictate any conflicting text’s merged position, while the Google Docs text, the merge’s target, will determine how conflicting styles are resolved.

(Unfortunately, comments are stripped out by Google Docs when uploading the Google Document, so they won’t survive a round-trip.)

Managing stories with the Links panel

Once an InDesign story is linked to a GDocs document using Place from Google Docs… or (in the Pro version) Export to Google Docs…, DocsFlow maintains the live link, which can be inspected in the normal InDesign Links panel. DocsFlow supports all the normal InDesign link functionality, except relinking.

InDesign (via DocsFlow) checks the status of each linked GDocs document fairly frequently, to see if it’s been edited since the original placement or last update. If it is ever edited, you’ll see the status column change to a yellow “warning” icon. If you go offline, the status changes to a grey “question mark” icon. If it goes missing entirely (e.g., it’s deleted on Google Docs), you’ll see the red “missing” icon.

Using DocsFlow, with the appropriate link selected in the Links panel where needed, you can:

  • Update: double-click the warning icon in the link’s status column, click on the update link (double-arrow) button in the panel, or select Update link from the link items’s contextual menu, to update the linked story, merging the latest GDocs changes.

    Or, to update all linked stories, alt/option-click the update link button in the panel with at least one link selected.

  • DocsFlow link panel menuEdit Original Document: click the edit-original (pencil) icon in the panel, select Edit > Edit Original, or select DocsFlow > Edit Original Document from the link item’s contextual menu, to open the original GDocs document in your default browser. When you return to InDesign, the story is automatically updated from GDocs (this is InDesign’s normal behavior for any link).
  • Visit Original Document: shift-click the edit-original (pencil) icon in the panel, or select DocsFlow > Visit Original Document from the link item’s contextual menu, to open the original GDocs document in your default browser but without auto-updating the story when you return to InDesign. This is useful when you want to visit the Google Doc to simply check its status or exchange comments with the author(s), and don’t want to automatically update the story on return.
  • Update Original Document (or and Visit or and Edit): see above, section Exporting and export-update-merging.
  • View status: in the Links panel link details (opened with the disclosure triangle or with the panel’s contextual menu Show Link Information Pane), you can see the metadata that DocsFlow digs out of the GDocs document and keeps up to date: name, format, size, author, placement date/time, modification date of the remote document, path to remote document, etc.
  • Go to story: click the goto link button in the panel or select Go to link from the item’s contextual menu, to move to that story in the InDesign document.
  • Unlink: select Unlink from the item’s contextual menu, to unlink the story from the GDocs document.

See handling conflicts for details on how DocsFlow handles merge-update conflicts.

Who-changed-what after a story update

Each time you update a story from a linked Google Docs document or spreadsheet, DocsFlow performs a merge-update rather than simply letting InDesign replace the story contents.

DocsFlow looks at the previous state of the linked document (privately saved in the InDesign document) and the current state of the linked document, and computes the “difference” between the two, to get the current set of changes to be applied. Then, DocsFlow applies those differences and updates the current InDesign story by merging in the differences.

If you want to know which side made which changes, you can open the InDesign Story Editor to see which side changed what. Read on for how conflicts are handled.

Handling conflicts

Each time you update a story from a linked Google Docs text or spreadsheet document, DocsFlow (behind the scenes) performs a merge-update rather than simply letting InDesign replace the story contents.

DocsFlow looks at the previous state of the linked document (privately saved in the InDesign document) and the current state of the linked document, and computes the “difference” between the two, to get the current set of changes to be applied. Then, DocsFlow applies those differences and updates the current InDesign story by merging in the differences.

When there are conflicts in this merge-update process, the linked Google Docs text/spreadsheet always “wins” for content order and the InDesign story always “wins” for formatting. For example, when updating an InDesign story from a Google Docs document, if the same piece of text has been moved in both, then DocsFlow will let the Google Docs document or spreadsheet determine the location of the resulting piece of text in the merged InDesign story. Similarly, if both have style changes to the same piece of text, then DocsFlow will let the InDesign story determine how the resulting piece of text is styled.

When there are content conflicts of the following kinds (formatting conflicts are never reported), DocsFlow will alert you by inserting a note (author “DocsFlow”) at the point of conflict:

  • insertions were made on both sides at the same point;
  • an insertion was made inside text that no longer exists on the other side;
  • content was moved on both sides in an incompatible way.

After every update, you should check for conflicts using the Notes panel, and delete them after review. If you enable the # of notes column in your Links panel, you can quickly see how many notes are in your story at a glance. Notes can be made visible with View > Extras > Show Notes, and you can delete them all at once from the Type > Notes menu.

Working online vs offline

Note that you must have Internet connectivity when using DocsFlow, at least when placing stories, checking story status, or updating stories.

Going offline at times is no problem—story status will show as “unknown” and you can’t place new GDocs stories, nor update existing linked GDocs stories—, but you can continue working normally in InDesign, including editing linked stories.

You’ll eventually need to reconnect to continue working with DocsFlow, and, once you do, on the next update, DocsFlow will merge any Google Docs changes with your local edits.

Security considerations

If you directly sign in to Google Docs, DocsFlow stores your user name and password in your private preferences, and they never even get near any document contents.

If you use the browser-based sign in (“OAuth,” technically), then DocsFlow only stores a couple of access tokens in your private preferences, and keeps no record of your user name and password.

DocsFlow communicates with Google Docs using the https: protocol, which is encrypted and secure (the same as you use when using your bank site in the browser). Your user name and password are never sent on non-secure channels.

Tips and techniques

From the simple to the sublime:

  • Assign a keyboard shortcut (Edit > Keyboard Shortcuts…) to Place from Google Docs… (in the File product area), if you’re going to use it frequently.

    E.g., you might assign control/command-shift-D as a counterpart to the normal Place… shortcut control/command-D, as illustrated in the screen shot.

  • Option/alt-click on the update link button in the Links panel (with at least one link selected) to update all stories in the current document.
  • Using drag and drop from Google Drive for placement, you can use standard Finder or Windows Explorer techniques for tracking what you’ve done, e.g., by tagging files you’ve already placed, or tagging files based on in what section of target publication section they’re placed.
  • You can link multi-frame layouts to a single GDocs document, by applying paragraph Keep Settings > Start Paragraph: In Next Frame or On Next Page to the first paragraph of each frame. This would be somewhat fragile in that overflow of a given frame would upset the layout, but if you give plenty of depth to each frame, it could work in controlled settings.

    (We’re thinking about ways to do this much more generally, in future releases.)

    In this case, you could disable InDesign’s Check Links Before Opening Document setting in Preferences > File Handling > Links. Link status should be updated just as quickly (depending on Google, of course) but in the background without progress bars, so you could get right to work on the InDesign document.

  • This is just an idea, and would require some serious fiddling, but it should be possible to set up a GDocs template document with the proper font size and margin, that will approximate a given column width in the finished InDesign document, such that number of lines in the GDocs document will roughly equal the same lines in an InDesign column.
  • To collaborate with an editor/writer on a given GDocs document, even in real time, you can use the comments stream for the document in question, accessed from the Comments > Show comment stream drop-down menu in the upper right, in the new GDocs layout.

    For example, when you’ve finished one round of layout that includes the given document, you could notify the writer in a comment on that document that gives them feedback about the story.

    You can also use comment-only access when sharing documents, a new feature in GDocs, so you can share documents for comments without worrying about accidental editing.

  • To collaborate with a group of editors and writers on a whole InDesign document, create and share a “status document” in Google Docs (either a document or a spreadsheet) with each participant. You could list each story involved in the InDesign document, along with comments and status updates. Everyone involved in the group could keep this document open at all times, for a real-time view.

    For example, if a given story needs to be edited to be shorter, you could change the status document entry for the given story requesting the change.

    (We’re thinking about ways to at least partially automate this idea.)

Workflow patterns

It’s helpful to think ahead about how you’ll actually use DocsFlow in your workflow. Here are some very general recommendations.

Converting your workflow

If you’re drowning in Word files, converting your workflow to DocsFlow is fairly easy: either upload all the Word (or other word processor) files for a given publishing project to GDocs and share them with the original senders for them to edit there, or have the senders upload them themselves and share them with you. Then place each such uploaded document with DocsFlow, and have everyone edit the shared Google Docs document instead of sending you further Word documents.

Edit in Google Docs, layout in InDesign

Unless you’re using the Pro version which can export to Google Docs, one workflow pattern that works well is to do the bulk of the text editing in GDocs, and the layout and formatting in InDesign.

Of course, because DocsFlow does merge the changes from both sides on an update, you can mix things up a bit—such as making something bold or italic in GDocs, or making small edits in InDesign—, but going back to GDocs to do major editing (use edit original freely) may work best: all editors collaborating on the story will see the story text largely as it will be published, without having to view the InDesign document.

Don’t format in GDocs

The flip side of the above pattern is that you should do little or no formatting on the GDocs side, or as little as you can get away with. You can set up your character and paragraph style mapping to ignore formatting of any given type when importing from GDocs, if you want to enforce this pattern, but, in any case, you should basically edit for content in GDocs and avoid formatting beyond the real basics.

Use DocsFlow > Export to Google Docs and Visit for assigning stories

If you’re setting up a publication and need to assign stories, one approach is to create the story (empty or with skeletal contents, perhaps giving the title and general synopsis), and then export it to Google Docs under a suitable name (e.g., the story’s title) and visit the newly-created document. From there, you can share the new Google Docs document with the authors or editors who’ll be working on it.

Unlink stories for isolation

Whenever you’re sure you’re done with editing on GDocs and no longer want to be bothered by changes, or risk updating the InDesign story by accident, you can simply unlink the story in question using the Links panel.

Appendix: How DocsFlow translates Google Docs documents

DocsFlow translates a GDocs document to an InDesign story format in the “least surprising” way it can. Not everything can translate perfectly, of course, so the less exotic formatting features you use in GDocs, the better.

  • A line break (Shift-Return) in GDocs translates into the a line break in InDesign.
  • A paragraph return in a GDocs document translates into a paragraph return.
  • By default, any paragraph in GDocs translates into a paragraph in InDesign with the style given by the kind of GDocs paragraph: Normal Text translates into [Basic Paragraph], Title into DocsFlow:Title, Subtitle into DocsFlow:Subtitle, Heading 1 into DocsFlow:Heading 1, and so forth, through Heading 6. (DocsFlow creates these styles on demand, if needed, and uses the style group DocsFlow to minimize document pollution. And any paragraph styles you map use your mapped style, not these defaults.)
  • Bulleted list items translate into paragraphs of style DocsFlow:Bulleted item and numbered list items translate into paragraphs of style DocsFlow:Numbered item.
  • A horizontal line in GDocs translates into a standalone paragraph of style DocsFlow:Horizontal rule. (So you might want to avoid the use of these.)
  • Tables translate as InDesign tables.
  • Pictures translate as anchored graphic frames with embedded graphics.
  • Hyperlinks translate as InDesign hyperlinks.
  • Comments translate as InDesign notes.
  • Page breaks translate as InDesign frame breaks.
  • Cross-references and bookmarks translate into InDesign cross-references and bookmarks.

DocsFlow uses reasonable defaults for all paragraph and character formats it imports from GDocs, based on the original GDocs content, but if you care about these details on initial import, you should either define the DocsFlow:Title, etc., styles, or map to your own styles.

WordPress.org

© 2010 Em Software - Business WordPress Theme by ThemeShift